Skip to main content

We are currently running version 3.0 of Maximizer. After loading Pervasive SQL 2000 (PSQL) (this for the installation of another database) client on a laptop Maximizer stopped working. We uninstalled the PSQL but still get an error when trying to run Maximizer.

"Data Manager returned an error code of 8020"
"An unidentified error has occurred at 'Record Manager' file.

For info: we don't run Maximizer through btrieve just use the basic network sharing option. Have tried re-instlling Maximizer.
Running Novell Netware 4.11. Windows 98 on the client.

Anybody any ideas how to get around this?
Original Post

Replies sorted oldest to newest

Hi Chris,

Mmm. Maximizer 3.0 probably won't work completly correctly with Pervasive SQL 2000 due to some differences in the way buffer sizes are managed. However, I understand this is not really what you were trying to achieve.

All Maximizer 3 installations use btrieve and whats happening here is due to mixed messages getting to Maximizer as a result of the presence of btrieve 6.15 and 7.51 (Pervasive.SQL 2000)

Error 8020 means Maximizer found mixed component versions. I suggest you run the smartscout component in in the Prevasive.SQL 2000 control center this will allow you to see what's currently in use. The problem will probably relate to the version of WBTRV32.DLL present on your computers.

Pervasive.SQL 2000 normally loads a 42kbyte file dated 9/6/99

I'dont think it will be easy to get both 6.15 peer-to-peer and Pervasive 2000 client/server applications on the same PCs. However, It may be possible as most of the files do not share the same names. Some experimentation with the settings in the registry and with careful checking of file versions would be necessary. Unfortunalty I've not tried to get this specific combination working.

You may be interested to know that the latest Maximizer version (Enterprise 2000) uses the Pervasive.SQL 2000 database and so would be completely happy on your network. If you would be interested in details of the new features/upgrade costs please drop me an email at

Best Regards
Ian Wallace

I did'nt mention that I had already un-installed the Pervasive SQL from this machine.

Anyway I ran smartscout to identify all the PSQL components loaded on this machine & then zipped & removed them. Checked the version of WBTRV32.dll I replaced this with a version 10/04/96 from a pc running Maximizer 3.0 ok.

Rebooted but still the same error.

Does the wsock32.dll have any relavence 04/32/99 40,960. This is shown as a component loaded in the smartscout but I left it alone.

Best Regards
Chris Pawley
Hi Chris,

The fact that you're getting an 8xxx error suggests that you still have some Pervasive SQL files in use.

For peer to peer 6.15 32 bit build 430 you should have

wbtrv32.dll 2/12/97 68096bytes
w32mkde.exe 10/07/96 320512
w32mkrc.dll 09/24/96 110080
wbtrcall.dll 02/04/97 43472
nwlocale.dll 09/20/96 43408
wbtrvres.dll 04/19/95 4192
wbtrthnk.dll 07/15/96 5824

note the us dates! (I copied them)

Next check your PATH statement for C:\PVSW and make sure this folder has gone.

If you only have these components and still have a problem, a registry entry may be the problem. Delete all btrieve technologies and Pervasive keys in HKEY_LOCAL_MACHINE (only if your familiar with how to do this) and re-install Maximizer.

If you still have a problem it could be MXZDIR.DAT is in 7.51 format. Rename it in the maximizer program directory (most likley but not only possible location) and copy one in from another PC or open Maximizer and File/New to recreate the entries.


Ian Wallace

Add Reply

Copyright 2007-2018 Advoco Solutions Ltd. All Rights Reserved.
Link copied to your clipboard.